Microsoft 365 Users Experiencing Email Delivery Delays

Incident

Microsoft 365 Users Experiencing Email Delivery Delays

Status: closed
Start:
End:
Duration: 3 days 6 hours 23 minutes
Affected Components:
Identified

A subset of Microsoft 365 Exchange Online users may experience delays or failures receiving e-mails sent by Trimble. This is an issue within the Microsoft 365 ecosystem and is not caused by Trimble systems or infrastructure. Microsoft is currently analyzing the behavior and review service telemetry to identify the underlying cause and determine the most effective mitigation. As we receive additional information from Microsoft, we will provide updates. For the latest information, please visit the Service Health page within your Microsoft 365 portal.

Update

Microsoft has identified a specific anti-spam filtering model that is affecting a subset of email traffic. As an initial mitigation, Microsoft is allow-listing the affected IP addresses that were subject to throttling. They are also working to disable the filtering model responsible for the impact.

Update

Telemetry shows that the service is performing as expected for new emails and this is in line with organizations confirming that the issue no longer occurring. We're monitoring email queues and performing final validations to confirm the issue is fully resolved.

Resolved

Microsoft has mitigated the Exchange Online issue that caused delays or failures when receiving emails sent by Trimble. Email delivery has returned to normal, and no further impact is expected. This incident originated within the Microsoft 365 ecosystem and was not caused by Trimble systems or infrastructure.