Central US SMTP Relay Servers – Degraded Availability

Incident

Central US SMTP Relay Servers – Degraded Availability

Status: closed
Start:
End:
Duration: 54 minutes
Affected Components:
Identified

Trimble Cloud Services is aware of an issue affecting the Central US SMTP Relay Servers, which may be causing degraded availability for some customers. Our teams are actively investigating the issue and working to restore normal service as quickly as possible. We will provide additional updates as more information becomes available.

Monitoring

Trimble Cloud Services has implemented a fix for the Central US SMTP Relay Server issue, and service availability has returned to expected levels. We are continuing to monitor the environment to ensure mail flow remains stable. Additional updates will be provided if any further impact is identified.

Resolved

Trimble Cloud Services has confirmed that the Central US SMTP Relay Server issue has been resolved.

Mail flow has returned to normal, and we have completed monitoring with no further impact observed. We appreciate your patience while our teams worked to resolve this issue.