Upcoming Emergency Maintenance — USEast2 CrushFTP (Sun, Sept 28 @ 1:00 PM ET)

Maintenance

Upcoming Emergency Maintenance — USEast2 CrushFTP (Sun, Sept 28 @ 1:00 PM ET)

Status: closed
Start:
End:
Duration: 45 minutes
Affected Components:
TTE Crush Portal (Azure East US 2)
Update

 To ensure we continue delivering reliable and secure services we will be performing emergency maintenance on the USEast2 CrushFTP Server 

  • Date: Sunday, September 28

  • Start Time: 1:00 PM (Eastern)

  • Expected End Time: 1:45 PM (Eastern)

  • Expected Impact: SFTP services may be unavailable for up to 45 minutes.

    • WorkOptima, Synergize, and EDI transactions utilizing CrushFTP may be delayed.

  • Note: The Citrix portal will remain fully operational during this maintenance.


We appreciate your understanding as we complete this critical work to ensure continued stability and performance.

Thank you, Trimble Transportation Cloud Services


Resolved

The emergency maintenance on the USEast2 CrushFTP Server has been completed, and services were fully restored at 1:45 PM Eastern Time (17:45 UTC) on Sunday, September 28, 2025. SFTP services are operating normally, and any queued WorkOptima, Synergize, and EDI transactions appear to be processing as expected.

All other applications, including the Citrix Portal and TMS software, remained available throughout. If you notice any lingering issues or unexpected behavior, please contact utilizing one of the methods listed at https://transportation.trimble.com/customer-support. 

Thank you for your patience while we worked to ensure reliable and secure service.