D2Link Services Unavailable
Incident
2025-08-09T12:59:00.0000000Z
D2Link Services Unavailable
Status: closed
Start:
2025-08-09T12:43:00.0000000Z
End:
2025-08-09T12:59:00.0000000Z
Duration: 16 minutes
Affected Components:
TMWSuite SaaS
TruckMate SaaS
Update
2025-08-09T12:43:00.0000000Z
2025-08-09T12:43:00.0000000Z
We are currently aware of and investigating issues affecting D2Link. Our team is working to identify the cause and restore normal service as quickly as possible. We will provide updates as more information becomes available.
Resolved
2025-08-09T12:59:00.0000000Z
2025-08-09T12:59:00.0000000Z
Resolved — The issues affecting D2Link have been identified and resolved. All services are now operating normally. We will continue to monitor to ensure full stability.